aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2010-02-03 20:24:13 +0100
committerJoe Damato <ice799@gmail.com>2010-11-28 20:07:58 -0800
commit584929c4409d55c3483caca7bdf6ba85f5b20f14 (patch)
tree087b714d6be4a13236017c9f54a471f7595c553b /Makefile.am
parent747c73d5b7d66d312a1b1a293e67f9ddf2f17d93 (diff)
downloadltrace-584929c4409d55c3483caca7bdf6ba85f5b20f14.tar.gz
autotoolization: add basic autotools infrastructure
This patch add a basic autotools infrastructure to ltrace. Native compilation on i386, x86_64 and ppc. Cross compilation has been tested against arm. Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am102
1 files changed, 102 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..994a4b5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,102 @@
+SUBDIRS = \
+ sysdeps
+
+AM_CPPFLAGS = \
+ $(libelf_CFLAGS) \
+ -DSYSCONFDIR=\"$(sysconfdir)\"
+
+noinst_LTLIBRARIES = \
+ libltrace.la
+
+libltrace_la_SOURCES = \
+ breakpoints.c \
+ debug.c \
+ demangle.c \
+ dict.c \
+ display_args.c \
+ ltrace-elf.c \
+ execute_program.c \
+ handle_event.c \
+ libltrace.c \
+ options.c \
+ output.c \
+ proc.c \
+ read_config_file.c \
+ summary.c
+
+libltrace_la_LIBADD = \
+ $(libelf_LIBS) \
+ $(liberty_LIBS) \
+ $(libsupcxx_LIBS) \
+ sysdeps/libos.la
+
+
+bin_PROGRAMS = \
+ ltrace
+
+ltrace_SOURCES = \
+ main.c
+
+ltrace_LDADD = \
+ libltrace.la
+
+
+noinst_HEADERS = \
+ common.h \
+ debug.h \
+ defs.h \
+ demangle.h \
+ dict.h \
+ ltrace-elf.h \
+ ltrace.h \
+ options.h \
+ output.h \
+ read_config_file.h
+
+dist_man1_MANS = \
+ ltrace.1
+
+dist_doc_DATA = \
+ COPYING \
+ README \
+ TODO \
+ BUGS \
+ ChangeLog
+
+dist_sysconf_DATA = \
+ etc/ltrace.conf
+
+EXTRA_DIST = \
+ .gitignore \
+ autogen.sh \
+ ltrace.spec \
+ \
+ debian/changelog \
+ debian/compat \
+ debian/control.in \
+ debian/copyright \
+ debian/rules
+
+MAINTAINERCLEANFILES = \
+ configure \
+ Makefile.in \
+ aclocal.m4 \
+ config/autoconf/compile \
+ config/autoconf/config.guess \
+ config/autoconf/config.sub \
+ config/autoconf/depcomp \
+ config/autoconf/install-sh \
+ config/autoconf/ltmain.sh \
+ config/autoconf/mdate-sh \
+ config/autoconf/missing \
+ config/autoconf/texinfo.tex \
+ libtool.m4 \
+ ltoptions.m4 \
+ ltsugar.m4 \
+ ltversion.m4 \
+ lt~obsolete.m4 \
+ $(DIST_ARCHIVES)
+
+maintainer-clean-local:
+ -chmod -R a+rw $(distdir)
+ -rm -fr $(distdir)