aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zwelch@codesourcery.com>2010-12-08 18:55:13 -0800
committerJoe Damato <ice799@gmail.com>2010-12-10 00:39:23 -0800
commitd0fafff5e3722daa00676b2f12111ffa77d57e16 (patch)
tree7999102fdb0ac6f83a27fee445f4a34245a8108d /Makefile.am
parentdfb873a9182075176c9e161df155c57ac2590ce1 (diff)
downloadltrace-d0fafff5e3722daa00676b2f12111ffa77d57e16.tar.gz
Switch CPPFLAGS and LDFLAGS to AM_ variants
Like CFLAGS, CPPFLAGS and LDFLAGS should not be set directly by the configure script, because the user can override them during 'make' (and that will break the build). Instead, the AM_CPPFLAGS and AM_LDFLAGS variables must be used to set options from configure; so, make it so. Signed-off-by: Zachary T Welch <zwelch@codesourcery.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a0410..6c299d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@ SUBDIRS = \
. \
testsuite
-AM_CPPFLAGS = \
+AM_CPPFLAGS += \
$(libelf_CFLAGS) \
-DSYSCONFDIR=\"$(sysconfdir)\"