aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIan Wienand <ianw@ieee.org>2006-02-16 13:00:00 +0100
committerIan Wienand <ianw@debian.org>2006-02-16 13:00:00 +0100
commite1cae5bc98bdc27e6915fce7b206093b654e4dab (patch)
tree8a36c04e8541a280cf226e5f9353f05ac8ccd0b4 /debian
parent35d233e30be3ffff698b1847fb7fc3fd28259357 (diff)
downloadltrace-e1cae5bc98bdc27e6915fce7b206093b654e4dab.tar.gz
Version 0.3.37-1
* Non-maintainer upload * Makefile.in: install documentation into share/doc * Create non-native package. * Add autoconf to build-deps
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules76
2 files changed, 9 insertions, 74 deletions
diff --git a/debian/changelog b/debian/changelog
index 0595daf..c052344 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
-ltrace (0.3.37.1) unstable; urgency=low
+ltrace (0.3.37-1) unstable; urgency=low
+ [ Ian Wienand ]
* Non-maintainer upload
* Start a "friendly takeover" from Juan
* Closes: #127503,#280608 -- update man page typos
@@ -11,6 +12,10 @@ ltrace (0.3.37.1) unstable; urgency=low
* See "upstream" ChangeLog for other changes (mostly warning fixes)
* Update README to point to Alioth home: http://ltrace.alioth.debian.org
+ [ Christoph Berg ]
+ * Create non-native package.
+ * Add autoconf to build-deps
+
-- Ian Wienand <ianw@ieee.org> Thu, 16 Feb 2006 11:51:32 +1100
ltrace (0.3.36-2) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 830cf26..7d69bc4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,74 +1,4 @@
-#! /usr/bin/make -f
-#
-# Copyright (C) 1997-2004 Juan Cespedes <cespedes@debian.org>
-#
+#!/usr/bin/make -f
-.PHONY: binary binary-indep binary-arch clean
-
-CFLAGS = -Wall -g
-INSTALL = install
-INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
-INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
-INSTALL_SCRIPT = $(INSTALL) -p -o root -g root -m 755
-INSTALL_DIR = $(INSTALL) -p -d -o root -g root -m 755
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -O0
-else
-CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-INSTALL_PROGRAM += -s
-endif
-
-build: Makefile config.h
- $(checkdir)
- $(MAKE) CFLAGS="${CFLAGS}"
- touch build
-
-Makefile config.h: configure Makefile.in config.h.in
- $(checkdir)
- ./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc
-
-configure: configure.ac
- $(checkdir)
- autoconf
-
-config.h.in: configure.ac
- $(checkdir)
- $(RM) config.h.in
- autoheader
-
-binary: binary-arch binary-indep
-
-binary-indep:
-
-binary-arch: build
- $(checkdir)
- test root = "`whoami`" || exit 1
- $(RM) -rf debian/tmp
-
- $(INSTALL_DIR) debian/tmp/DEBIAN
- cp debian/conffiles debian/tmp/DEBIAN
- $(MAKE) install DESTDIR=`pwd`/debian/tmp docdir=/usr/share/doc/ltrace INSTALL_PROGRAM="${INSTALL_PROGRAM}"
- $(RM) debian/tmp/usr/share/doc/ltrace/COPYING
- $(RM) debian/tmp/usr/share/doc/ltrace/ChangeLog
- cp -p debian/changelog debian/tmp/usr/share/doc/ltrace/changelog.Debian
- gzip -9f debian/tmp/usr/share/doc/ltrace/README debian/tmp/usr/share/doc/ltrace/changelog.Debian
- cp -p debian/copyright debian/tmp/usr/share/doc/ltrace
- gzip -9f debian/tmp/usr/share/man/man1/*
- dpkg-shlibdeps debian/tmp/usr/bin/ltrace
- dpkg-gencontrol -isp
- chown -R root.root debian/tmp
- chmod -R u=rwX,go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-clean: configure config.h.in
- $(checkdir)
- $(RM) build debian/files debian/substvars
- -$(MAKE) distclean
- $(RM) -r debian/tmp
-
-define checkdir
- test -f ltrace.c -a -f debian/rules
-endef
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk