aboutsummaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog130
1 files changed, 130 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f98e47c..a8a1f6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,133 @@
+mtools (4.0.37) stable; urgency=low
+
+ * Removed mclasserase commands, which doesn't fit the coding
+ structure of the rest of mtools
+ * Add support to -i option to mcd
+ * Document -i in mtools.1
+ * Fix a missing commad error in floppyd_io.c
+
+ -- Alain Knaff <alain@knaff.lu> Sun, 26 Dec 2021 18:57:02 +0100
+mtools (4.0.36) stable; urgency=low
+
+ * Fix error status of recursive listing of empty root directory
+ * If recursive listing, also show matched files at level one
+ * Use "seekless" reads & write internally, where possible
+ * Text mode conversion refactoring
+ * Misc refactoring
+
+ -- Alain Knaff <alain@knaff.lu> Sun, 21 Nov 2021 16:41:10 +0100
+mtools (4.0.35) stable; urgency=low
+
+ * Fix cluster padding at end of file in batch mode, and add comments
+ about what happens here
+
+ -- Alain Knaff <alain@knaff.lu> Fri, 6 Aug 2021 20:13:59 +0200
+mtools (4.0.34) stable; urgency=low
+
+ * Fix mcopy -s issue
+
+ -- Alain Knaff <alain@knaff.lu> Fri, 23 Jul 2021 12:41:11 +0200
+mtools (4.0.33) stable; urgency=low
+
+ * Fix support for partitions (broken in 4.0.30)
+ * Portability fixes for Solaris 10 and 11
+ * General simplification of configure script, and largefile handling
+ * Tested and fixed for platforms *without* largefile support
+ * In cases where lseek works with 32-bit offsets, prefer lseek64 over llseek
+ * Fixed floppy sector size handling on platforms that are not Linux
+ * Added support for image files on command line to mcat
+
+ -- Alain Knaff <alain@knaff.lu> Sat, 17 Jul 2021 18:31:38 +0200
+mtools (4.0.32) stable; urgency=low
+
+ * Simplify algorithm that choses filesystem parameters for format, and align
+ it more closely with what Win7 does
+
+ * Fix mformatting XDF when XDF not explicitly specified on mformat command
+ line
+
+ * easier way to enter sizes on mformat command line (mformat -C -T 1440K)
+
+ * For small sizes, mformat assumes floppy geometries (heads 1 or 2,
+ tracks 40 or 80)
+
+ * Handle attempts to mformat too small filesystems more gracefully
+
+ * Enable minfo to print out additional mformat command line parameters, if
+ the present filesystem uses non-default values for these
+
+ * minfo no longer prints bigsect if smallsect is set
+
+ * for remap filter, error when trying to write non-zero data to unmapped
+ sectors
+
+ * Fix misc compilation warnings occuring when disabling certain features
+ (largefiles, raw-term)
+
+ -- Alain Knaff <alain@knaff.lu> Sat, 10 Jul 2021 14:31:23 +0200
+mtools (4.0.31) stable; urgency=low
+
+ * Move Linux-specific block device sizing code into
+ linux-specific section of devices.c
+ * Error messages for all failure cases on fs_init failure
+ * Fix compilation without XDF support (OpenImage signature)
+ * Fix polarity of format_xdf command-line parameter of mformat
+ * In XDF_IO retry enough times to actually succeed, even if
+ FDC was in a bad state before
+ * Remove useless buffer flushing triggered when giving up a
+ reference to a stream node that is still referenced
+ elsewhere.
+ * Clearer error message if neither size nor geometry of drive
+ to be mformatted is known
+ * In mformat, make Fs dynamically allocated rather than
+ on-stack, so as to be able to use utilities supplied by
+ stream.c
+ * Remove duplicate writing of backup boot sector
+ * Allow to infer geometry if only size is specified
+ * Protect against attempt to create zero-sized buffer
+ * Code simplification in mattrib
+ * Remove dead code in mpartition
+
+ -- Alain Knaff <alain@knaff.lu> Sat, 19 Jun 2021 17:22:27 +0200
+mtools (4.0.30) stable; urgency=low
+
+ * Fixed XDF floppy disk access
+ * Fixed faulty behavior at end of image in mcat
+ * Device/Image size handling refactoring
+ * allow remap to write to zero-backed sectors (may happen if
+ buffer is flushed, and is not an error in that case)
+ * Raise an error when trying to mcopy multiple source files
+ over a single destination file (rather than directory)
+ * fix handling of "hidden" sectors (is a 2 byte quantity on
+ small disks, not 4 byte as previously assumed)
+ * Modernize partition support. Tuned consistency check to
+ actually check about important issues (such as overlapping
+ partitions) rather than stuff nobody else cares about
+ (alignment on entire cylinder boundaries)
+ * Move various "filter" options (partition, offset, swap,
+ scsi) into separate classes, rather than leaving almost
+ everything in plain_io
+ * Simplify and centralize geometry handling and LBA code
+ * Fix some more more compiler warnings
+
+ -- Alain Knaff <alain@knaff.lu> Thu, 17 Jun 2021 22:23:39 +0200
+mtools (4.0.29) stable; urgency=low
+
+ * -Fix bug in cluster preallocation, which was accidentally introduced by compiler warning "fixes" from v4_0_28
+
+ -- Alain Knaff <alain@knaff.lu> Mon, 31 May 2021 19:07:43 +0200
+mtools (4.0.28) stable; urgency=low
+
+ * Support remapping of data (for not-quite linear floppy image files)
+ * Re-open floppy devices read-write if geometry parameters need to be changed
+ * relax consistency checks in mpartition (partitions created by current fdisk would almost never pass these checks)
+ * Fix some compiler warnings
+
+ -- Alain Knaff <alain@knaff.lu> Sun, 30 May 2021 18:33:09 +0200
+mtools (4.0.27) stable; urgency=low
+ * Fix type error in calls to iconv functions
+
+ -- Alain Knaff <alain@knaff.lu> Fri, 16 Apr 2021 20:54:49 +0200
mtools (4.0.26) stable; urgency=low
* Fix compilation on Macintosh
* Ignore image file locking errors if we are performing a read-only access anyways