aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDon Turner <donturner@google.com>2018-08-07 20:28:27 +0100
committerDon Turner <donturner@google.com>2018-08-07 20:28:27 +0100
commit2ee898aefa28be2ceac8f499b768550547373d1c (patch)
tree5a5151e28ea2d8320491edf09aba76acc99a95be /CMakeLists.txt
parentddcd3415bcdd10d7f8ac34249b1df6e051221e4d (diff)
downloadoboe-2ee898aefa28be2ceac8f499b768550547373d1c.tar.gz
Make OBOE_ENABLE_LOGGING public
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46ef3d0c..4f65c2a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,7 +34,6 @@ target_compile_options(oboe
PRIVATE -std=c++11 -Wall "$<$<CONFIG:DEBUG>:-Werror>" -Ofast)
# Enable logging for debug builds
-target_compile_definitions(oboe PRIVATE "$<$<CONFIG:DEBUG>:OBOE_ENABLE_LOGGING=1>")
-
+target_compile_definitions(oboe PUBLIC "$<$<CONFIG:DEBUG>:OBOE_ENABLE_LOGGING=1>")
target_link_libraries(oboe PRIVATE log OpenSLES)