aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorggfan <gfan@google.com>2018-07-27 16:09:09 -0700
committergfan <gfan@google.com>2018-07-30 12:58:37 -0700
commit32c674378bacb1fd8e384db879197f3ad54338f9 (patch)
treec4277618122102adc5357c8a133abd58d14a4324 /CMakeLists.txt
parent2778e886e1c653da899135626c20ac77b81e7891 (diff)
downloadoboe-32c674378bacb1fd8e384db879197f3ad54338f9.tar.gz
Added OBOE_ENABLE_LOGGING to guard against logging per github issue 175
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be3b572d..e18d86a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,4 +35,7 @@ target_compile_options(oboe PRIVATE -std=c++11
PRIVATE "$<$<CONFIG:DEBUG>:-Werror>"
PRIVATE "$<$<CONFIG:RELEASE>:-Ofast>")
+# Enable logging when debugging
+# target_compile_options(oboe PUBLIC -DOBOE_ENABLE_LOGGING=1)
+
target_link_libraries(oboe PRIVATE log OpenSLES)