aboutsummaryrefslogtreecommitdiff
path: root/src/extensions/ngram/Makefile.am
diff options
context:
space:
mode:
authorAlexander Gutkin <agutkin@google.com>2012-09-12 18:11:43 +0100
committerAlexander Gutkin <agutkin@google.com>2012-09-12 18:11:43 +0100
commitdfd8b8327b93660601d016cdc6f29f433b45a8d8 (patch)
tree968ec84b8e32ad73ec18d74334930f36b7471906 /src/extensions/ngram/Makefile.am
parentf4c12fce1ee58e670f9c3fce46c40296ba9ee8a2 (diff)
downloadopenfst-dfd8b8327b93660601d016cdc6f29f433b45a8d8.tar.gz
Updated OpenFST version to openfst-1.3.2-CL32004048 from Greco3.
Change-Id: I19b0db718256b35c0e3e5a7315f1ed6335e6dcac
Diffstat (limited to 'src/extensions/ngram/Makefile.am')
-rw-r--r--src/extensions/ngram/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/extensions/ngram/Makefile.am b/src/extensions/ngram/Makefile.am
new file mode 100644
index 0000000..e909eaf
--- /dev/null
+++ b/src/extensions/ngram/Makefile.am
@@ -0,0 +1,10 @@
+AM_CPPFLAGS = -I$(srcdir)/../../include $(ICU_CPPFLAGS)
+
+libfstdir = @libfstdir@
+libfst_LTLIBRARIES = libfstngram.la ngram-fst.la
+
+ngram_fst_la_SOURCES = bitmap-index.cc ngram-fst.cc nthbit.cc
+ngram_fst_la_LDFLAGS = -module
+
+libfstngram_la_SOURCES = bitmap-index.cc ngram-fst.cc nthbit.cc
+libfstngram_la_LDFLAGS = -version-info 0:0:0