aboutsummaryrefslogtreecommitdiff
path: root/src/include/Makefile.am
diff options
context:
space:
mode:
authorIan Hodson <idh@google.com>2012-05-30 21:27:06 +0100
committerIan Hodson <idh@google.com>2012-05-30 22:47:36 +0100
commitf4c12fce1ee58e670f9c3fce46c40296ba9ee8a2 (patch)
treeb131ed907f9b2d5af09c0983b651e9e69bc6aab9 /src/include/Makefile.am
parenta92766f0a6ba4fac46cd6fd3856ef20c3b204f0d (diff)
downloadopenfst-f4c12fce1ee58e670f9c3fce46c40296ba9ee8a2.tar.gz
Moved from GoogleTTS Change-Id: I6bc6bdadaa53bd0f810b88443339f6d899502cc8
Diffstat (limited to 'src/include/Makefile.am')
-rw-r--r--src/include/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/src/include/Makefile.am b/src/include/Makefile.am
new file mode 100644
index 0000000..b4e6213
--- /dev/null
+++ b/src/include/Makefile.am
@@ -0,0 +1,67 @@
+if HAVE_FAR
+far_include_headers = fst/extensions/far/compile-strings.h \
+fst/extensions/far/create.h fst/extensions/far/extract.h \
+fst/extensions/far/far.h fst/extensions/far/farlib.h \
+fst/extensions/far/farscript.h fst/extensions/far/info.h \
+fst/extensions/far/main.h fst/extensions/far/print-strings.h \
+fst/extensions/far/stlist.h fst/extensions/far/sttable.h
+endif
+
+if HAVE_PDT
+pdt_include_headers = fst/extensions/pdt/collection.h \
+fst/extensions/pdt/compose.h fst/extensions/pdt/expand.h \
+fst/extensions/pdt/info.h fst/extensions/pdt/paren.h \
+fst/extensions/pdt/pdt.h fst/extensions/pdt/pdtlib.h \
+fst/extensions/pdt/pdtscript.h fst/extensions/pdt/replace.h \
+fst/extensions/pdt/reverse.h fst/extensions/pdt/shortest-path.h
+endif
+
+script_include_headers = fst/script/arcsort.h fst/script/arg-packs.h \
+fst/script/closure.h fst/script/compile-impl.h fst/script/compile.h \
+fst/script/compose.h fst/script/concat.h fst/script/connect.h \
+fst/script/convert.h fst/script/decode.h fst/script/determinize.h \
+fst/script/difference.h fst/script/draw-impl.h fst/script/draw.h \
+fst/script/encode.h fst/script/epsnormalize.h fst/script/equal.h \
+fst/script/equivalent.h fst/script/fst-class.h fst/script/fstscript.h \
+fst/script/info-impl.h fst/script/info.h fst/script/intersect.h \
+fst/script/invert.h fst/script/map.h fst/script/minimize.h \
+fst/script/print-impl.h fst/script/print.h fst/script/project.h \
+fst/script/prune.h fst/script/push.h fst/script/randequivalent.h \
+fst/script/randgen.h fst/script/register.h fst/script/relabel.h \
+fst/script/replace.h fst/script/reverse.h fst/script/reweight.h \
+fst/script/rmepsilon.h fst/script/script-impl.h \
+fst/script/shortest-distance.h fst/script/shortest-path.h \
+fst/script/symbols.h fst/script/synchronize.h fst/script/text-io.h \
+fst/script/topsort.h fst/script/union.h fst/script/weight-class.h \
+fst/script/fstscript-decl.h fst/script/verify.h
+
+nobase_include_HEADERS = fst/arc.h fst/determinize.h fst/intersect.h \
+fst/queue.h fst/statesort.h fst/arcfilter.h fst/dfs-visit.h \
+fst/invert.h fst/randequivalent.h fst/string-weight.h \
+fst/difference.h fst/lexicographic-weight.h fst/randgen.h \
+fst/symbol-table.h fst/arcsort.h fst/encode.h fst/lock.h \
+fst/random-weight.h fst/synchronize.h \
+fst/epsnormalize.h fst/log.h fst/rational.h fst/test-properties.h \
+fst/cache.h fst/equal.h fst/arc-map.h fst/map.h fst/register.h fst/topsort.h \
+fst/closure.h fst/equivalent.h fst/matcher.h fst/matcher-fst.h fst/relabel.h \
+fst/union-find.h fst/compact-fst.h fst/expanded-fst.h fst/minimize.h \
+fst/replace.h fst/union.h fst/compat.h fst/factor-weight.h fst/state-map.h \
+fst/mutable-fst.h fst/reverse.h fst/util.h fst/complement.h \
+fst/flags.h fst/partition.h fst/reweight.h fst/vector-fst.h \
+fst/compose-filter.h fst/float-weight.h fst/product-weight.h \
+fst/rmepsilon.h fst/verify.h fst/compose.h fst/fst-decl.h \
+fst/project.h fst/rmfinalepsilon.h fst/visit.h fst/concat.h \
+fst/fst.h fst/properties.h fst/shortest-distance.h fst/weight.h \
+fst/connect.h fst/fstlib.h fst/prune.h fst/shortest-path.h \
+fst/const-fst.h fst/heap.h fst/push.h fst/state-table.h fst/slist.h \
+fst/pair-weight.h fst/config.h fst/tuple-weight.h fst/power-weight.h \
+fst/lookahead-matcher.h fst/types.h fst/add-on.h fst/label-reachable.h \
+fst/accumulator.h fst/interval-set.h fst/state-reachable.h \
+fst/lookahead-filter.h fst/generic-register.h fst/edit-fst.h \
+fst/replace-util.h fst/icu.h fst/string.h fst/signed-log-weight.h \
+fst/sparse-tuple-weight.h fst/sparse-power-weight.h fst/expectation-weight.h \
+fst/symbol-table-ops.h fst/bi-table.h \
+$(far_include_headers) \
+$(pdt_include_headers) \
+$(script_include_headers)
+