aboutsummaryrefslogtreecommitdiff
path: root/python/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyproject.toml')
-rw-r--r--python/pyproject.toml24
1 files changed, 23 insertions, 1 deletions
diff --git a/python/pyproject.toml b/python/pyproject.toml
index 6b4a236..0e82566 100644
--- a/python/pyproject.toml
+++ b/python/pyproject.toml
@@ -6,17 +6,39 @@ dynamic = ["version", "description"]
classifiers = [
"License :: OSI Approved :: Apache Software License"
]
-dependencies = ["protobuf>=4.22.0"]
+dependencies = [
+ "grpcio==1.57",
+ "protobuf>=4.22.0"
+]
[project.urls]
Source = "https://github.com/google/bt-test-interfaces"
+[project.optional-dependencies]
+dev = [
+ "pyright==1.1.298",
+ "types-psutil==5.9.5.16",
+ "types-setuptools==68.1.0.1",
+ "types-protobuf==4.24.0.1"
+]
+
[tool.flit.module]
name = "pandora"
[tool.flit.sdist]
include = ["_build", ".."]
+[tool.pyright]
+include = ["pandora"]
+exclude = ["**/__pycache__", "**/*_pb2.py"]
+typeCheckingMode = "strict"
+useLibraryCodeForTypes = true
+verboseOutput = false
+reportMissingTypeStubs = false
+reportUnknownLambdaType = false
+reportImportCycles = false
+reportPrivateUsage = false
+
[build-system]
requires = ["flit_core==3.7.1", "grpcio-tools>=1.51.1"]
build-backend = "_build.backend"