aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhayati ayguen <h_ayguen@web.de>2020-03-29 08:40:47 +0200
committerhayati ayguen <h_ayguen@web.de>2020-03-29 08:40:47 +0200
commit6e6120951fab9a7bbbf9f604bd028ddc01de5729 (patch)
treeec187ec40ca79444b927fd16163b0a0f56611bb1 /CMakeLists.txt
parentc974c1d9e336bdd790260d96044207424384613c (diff)
downloadpffft-6e6120951fab9a7bbbf9f604bd028ddc01de5729.tar.gz
update README and C standard: C99 doesn't require gcc extensions
Signed-off-by: hayati ayguen <h_ayguen@web.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dc5120..75f787c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,8 +10,10 @@ option(USE_KISS "use KissFFT in fft benchmark? - if exists in subdir" ON)
option(USE_ASAN "use GCC's address sanitizer?" OFF)
-set(CMAKE_C_STANDARD 90)
-set(CMAKE_C_EXTENSIONS ON) # required for gcc function attribures (inline)
+# C90 requires the gcc extensions for function attributes like always_inline
+# C99 provides the function attributes: no gcc extensions required
+set(CMAKE_C_STANDARD 99)
+set(CMAKE_C_EXTENSIONS OFF)
set(CMAKE_CXX_STANDARD 98)
set(CMAKE_CXX_STANDARD_REQUIRED ON)