aboutsummaryrefslogtreecommitdiff
path: root/pw_protobuf/CMakeLists.txt
diff options
context:
space:
mode:
authorWyatt Hepler <hepler@google.com>2021-02-03 08:45:10 -0800
committerWyatt Hepler <hepler@google.com>2021-02-03 19:36:05 +0000
commit9174147f7100f278662d30734fea16c926723d08 (patch)
tree6454ce3b94744f35c0024099c484a7c73210fbc0 /pw_protobuf/CMakeLists.txt
parentee8b0f6b15f405d6ceaaf6a564290b42843b3529 (diff)
downloadpigweed-9174147f7100f278662d30734fea16c926723d08.tar.gz
pw_protobuf_compiler: Avoid duplicate protobuf Python packages
For compatibility with Python packaging, each pw_protobuf_library target must have a unique root directory for its protos. If this is violated, the setup.py for the Python package is generated multiple times, resulting in flaky builds. This change ensures that no two pw_proto_library targets generate the same Python package and fixes existing conflicts in the Pigweed repo. Change-Id: Icbc13ceeb2fd329bc4fbf1e14ec039e98dc7e483 Reviewed-on: https://pigweed-review.googlesource.com/c/pigweed/pigweed/+/31740 Reviewed-by: Alexei Frolov <frolv@google.com>
Diffstat (limited to 'pw_protobuf/CMakeLists.txt')
-rw-r--r--pw_protobuf/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/pw_protobuf/CMakeLists.txt b/pw_protobuf/CMakeLists.txt
index 66fc333d3..44ed7dc9d 100644
--- a/pw_protobuf/CMakeLists.txt
+++ b/pw_protobuf/CMakeLists.txt
@@ -27,10 +27,10 @@ pw_auto_add_simple_module(pw_protobuf
pw_proto_library(pw_protobuf.codegen_test_protos
SOURCES
- pw_protobuf_protos/test_protos/full_test.proto
- pw_protobuf_protos/test_protos/imported.proto
- pw_protobuf_protos/test_protos/importer.proto
- pw_protobuf_protos/test_protos/non_pw_package.proto
- pw_protobuf_protos/test_protos/proto2.proto
- pw_protobuf_protos/test_protos/repeated.proto
+ pw_protobuf_test_protos/full_test.proto
+ pw_protobuf_test_protos/imported.proto
+ pw_protobuf_test_protos/importer.proto
+ pw_protobuf_test_protos/non_pw_package.proto
+ pw_protobuf_test_protos/proto2.proto
+ pw_protobuf_test_protos/repeated.proto
)