aboutsummaryrefslogtreecommitdiff
path: root/pw_log_zephyr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pw_log_zephyr/CMakeLists.txt')
-rw-r--r--pw_log_zephyr/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/pw_log_zephyr/CMakeLists.txt b/pw_log_zephyr/CMakeLists.txt
new file mode 100644
index 000000000..c4c71789e
--- /dev/null
+++ b/pw_log_zephyr/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright 2021 The Pigweed Authors
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+include($ENV{PW_ROOT}/pw_build/pigweed.cmake)
+
+if(NOT CONFIG_PIGWEED_LOG)
+ return()
+endif()
+
+pw_auto_add_simple_module(pw_log_zephyr
+ IMPLEMENTS_FACADE
+ pw_log
+ PUBLIC_DEPS
+ zephyr_interface
+ PRIVATE_DEPS
+ pw_preprocessor
+)
+pw_set_backend(pw_log pw_log_zephyr)
+zephyr_link_libraries(pw_log_zephyr)