aboutsummaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build13
1 files changed, 3 insertions, 10 deletions
diff --git a/test/meson.build b/test/meson.build
index 59a0d42..47dd33c 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -67,20 +67,13 @@ progs = [
'affine-bench',
]
-libtestutils = static_library(
- 'testutils',
- ['utils.c', 'utils-prng.c', config_h],
- dependencies : [dep_openmp, dep_m, dep_png, idep_pixman],
-)
-
foreach t : tests
test(
t,
executable(
t,
[t + '.c', config_h],
- link_with : libtestutils,
- dependencies : [dep_threads, dep_openmp, idep_pixman],
+ dependencies : [idep_pixman, libtestutils_dep, dep_threads, dep_openmp, dep_png],
),
timeout : 120,
is_parallel : true,
@@ -91,7 +84,7 @@ foreach p : progs
executable(
p,
p + '.c',
- link_with : libtestutils,
- dependencies : [dep_openmp, idep_pixman],
+ dependencies : [idep_pixman, libtestutils_dep, dep_openmp],
)
endforeach
+