aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarat Dukhan <marat@fb.com>2017-10-17 15:23:06 -0700
committerMarat Dukhan <marat@fb.com>2017-10-17 15:23:06 -0700
commit6f35d78916158a35723475546822b32de8a3b713 (patch)
treeaa080df7ff34b2c862320f08ffd8729b5daf9bf3 /CMakeLists.txt
parentbe01e8cf59f680e14bf5f1fc575a7a133a4a5d7d (diff)
downloadpthreadpool-6f35d78916158a35723475546822b32de8a3b713.tar.gz
Build tests and benchmarks in CMake build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd4b767..f849edb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,8 +6,8 @@ INCLUDE(GNUInstallDirs)
PROJECT(pthreadpool LANGUAGES C CXX)
# ---[ Options.
-OPTION(PTHREADPOOL_BUILD_TESTS "Build pthreadpool unit tests" OFF)
-OPTION(PTHREADPOOL_BUILD_BENCHMARKS "Build pthreadpool micro-benchmarks" OFF)
+OPTION(PTHREADPOOL_BUILD_TESTS "Build pthreadpool unit tests" ON)
+OPTION(PTHREADPOOL_BUILD_BENCHMARKS "Build pthreadpool micro-benchmarks" ON)
# ---[ CMake options
LIST(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)