aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Levasseur <rlevasseur@google.com>2019-02-27 09:54:56 -0800
committerCopybara-Service <copybara-piper@google.com>2019-02-27 09:55:15 -0800
commit75a22f4f01d467e6e57d429f4840127682c64c37 (patch)
treefc5279d4deff7030669911b5ed2171eaca66100b /setup.py
parent4d8d20d81ac29cc73fd716bc642f7a4a70e35200 (diff)
downloadabsl-py-75a22f4f01d467e6e57d429f4840127682c64c37.tar.gz
Make sdist include LICENSE files.
LICENSE files are required when distributing. The latest version (~40.8, I think) of setuptools includes licenses by default however, since we can't rely on such a new version of setuptools being used, just use MANIFEST.in instead. Resolves #94 PiperOrigin-RevId: 235938402
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2e80741..17371cc 100644
--- a/setup.py
+++ b/setup.py
@@ -76,6 +76,7 @@ setuptools.setup(
'*.tests', '*.tests.*', 'tests.*', 'tests',
]),
install_requires=INSTALL_REQUIRES,
+ include_package_data=True,
license='Apache 2.0',
classifiers=[
'Programming Language :: Python',