aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Levasseur <rlevasseur@google.com>2018-07-25 10:01:40 -0700
committerCopybara-Service <copybara-piper@google.com>2018-07-25 10:02:01 -0700
commitca28d0caec86efd32d5d1e46e99dffbb50712afe (patch)
tree0cf18acd03f8619415ea23dd4b238311f22eaaae /setup.py
parentb9288005aab82077486df06009cd5c26090782d7 (diff)
downloadabsl-py-ca28d0caec86efd32d5d1e46e99dffbb50712afe.tar.gz
Bump absl-py to version 0.3.0
New Features * app.call_after_init: Register functions to be called after app.run() is called. Useful for program-wide initialization that library code may need. * logging.log_every_n_seconds: like log_every_n, but based on elapsed time between logging calls. * absltest.mock: alias to unittest.mock (PY3) for better unittest drop-in replacement. For PY2, it will be available if mock is importable. Bug Fixes: * ABSLLogger.findCaller(): allow stack_info arg and return value for PY2 * Make stopTest locking reentrant: this prevents deadlocks for test frameworks that customize unittest.TextTestResult.stopTest. * Make --helpfull work with unicode flag help strings. PiperOrigin-RevId: 206010154
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f438cfc..023044e 100644
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,7 @@ with open(_README_PATH, 'rb') as fp:
setuptools.setup(
name='absl-py',
- version='0.2.2',
+ version='0.3.0',
description=(
'Abseil Python Common Libraries, '
'see https://github.com/abseil/abseil-py.'),