aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Levasseur <rlevasseur@google.com>2019-01-11 09:37:49 -0800
committerCopybara-Service <copybara-piper@google.com>2019-01-11 09:38:03 -0800
commit5b9923a37f252ff7cb3885dafadf09712d89d273 (patch)
tree848c341ec875b1577c0d0a47ac011e1c216e8c7f /setup.py
parenteb22f3bb6a7ec23443d4118ab8bdcb50f44938de (diff)
downloadabsl-py-5b9923a37f252ff7cb3885dafadf09712d89d273.tar.gz
Bump absl-py to version 0.7.0
New Features: * (bazel) testonly=1 has been removed from the testing libraries, which allows their use outside of testing contexts. * (flags) Multi-flags now accept any Iterable type for the default value instead of only lists. Strings are still special cased as before. This allows sets, generators, views, etc to be used naturally. * (flags) DEFINE_multi_enum_class: a multi flag variant of enum_class. * (testing) Most of absltest is now type-annotated. * (testing) Made AbslTest.assertRegex available under Python 2. This allows Python 2 code to write more natural Python 3 compatible code. (Note: this was actually released in 0.6.1, but unannounced) * (logging) logging.vlog_is_on: helper to tell if a vlog() call will actually log anything. This allows avoiding computing expansive inputs to a logging call when logging isn't enabled for that level. Bug Fixes: * (flags) Pickling flags now raises an clear error instead of a cryptic one. Pickling flags isn't supported; instead use flags_into_string to serialize flags. * (flags) Flags serialization works better: the resulting serialized value, when deserialized, won't cause --help to be invoked, thus ending the process. * (flags) Several flag fixes to make them behave more like the Absl C++ flags: empty --flagfile is allowed; --nohelp and --help=false don't display help * (flags) An empty --flagfile value (e.g. "--flagfile=" or "--flagfile=''" doesn't raise an error; its not just ignored. This matches Abseil C++ behavior. Other Notable Changes: * (bazel) Now using the @bazel_tools http_archive rules instead of native new_http_archive rules; this also allows building with Bazel 0.2.0 without extra incompatibility disable flags. * (flags) Flag serialization is now deterministic: this improves Bazel build caching for tools that are affected by flag serialization. PiperOrigin-RevId: 228895370
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8187e18..2e80741 100644
--- a/setup.py
+++ b/setup.py
@@ -64,7 +64,7 @@ with open(_README_PATH, 'rb') as fp:
setuptools.setup(
name='absl-py',
- version='0.6.1',
+ version='0.7.0',
description=(
'Abseil Python Common Libraries, '
'see https://github.com/abseil/abseil-py.'),