aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYilei Yang <yileiyang@google.com>2019-08-26 12:51:04 -0700
committerCopybara-Service <copybara-worker@google.com>2019-08-26 12:51:27 -0700
commit9f7787c639209d564c51e07971107f5a8490d90e (patch)
tree6ffa38800ea3ad41e85b5502f6edc29c31c77467 /setup.py
parenta89cf364c6992168405a971966ce5fa53715f327 (diff)
downloadabsl-py-9f7787c639209d564c51e07971107f5a8490d90e.tar.gz
Bump absl-py to version 0.8.0.
Changelog: ### Added * (testing) `absltest.expectedFailureIf`: a variant of `unittest.expectedFailure` that allows a condition to be given. ### Changed * (bazel) Tests now pass when bazel `--incompatible_allow_python_version_transitions=true` is set. * (bazel) Both Python 2 and Python 3 versions of tests are now created. To only run one major Python version, use `bazel test --test_tag_filters=-python[23]` to ignore the other version. * (testing) `assertTotallyOrdered` no longer requires objects to implement `__hash__`. * (testing) `absltest` now integrates better with `--pdb_post_mortem`. * (testing) `xml_reporter` now includes timestamps to testcases, test_suite, test_suites elements. ### Fixed * #99: `absl.logging` no longer registers itself to `logging.root` at import time. * #108: Tests now pass with Bazel 0.28.0 on macOS. PiperOrigin-RevId: 265519766 Change-Id: Ie80c838f2436cd0c7407f29ca29e74e0abe4c4da
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 399166b..d628a30 100644
--- a/setup.py
+++ b/setup.py
@@ -64,7 +64,7 @@ with open(_README_PATH, 'rb') as fp:
setuptools.setup(
name='absl-py',
- version='0.7.1',
+ version='0.8.0',
description=(
'Abseil Python Common Libraries, '
'see https://github.com/abseil/abseil-py.'),