aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorwbond <will@wbond.net>2015-06-15 09:09:17 -0400
committerwbond <will@wbond.net>2015-06-15 09:09:17 -0400
commitb9b7597b6f4f770bc7c4045236123aa28a402e2c (patch)
tree44949fc97e211f0525bcb17c7acbde3de54ab251 /setup.py
parente91513efcd9714573e6bcefd3bb4cd9e680f04f7 (diff)
downloadasn1crypto-b9b7597b6f4f770bc7c4045236123aa28a402e2c.tar.gz
Docs, package infrastructure
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..6df9758
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,34 @@
+from setuptools import setup, find_packages
+import asn1crypto
+
+
+setup(
+ name='asn1crypto',
+ version=asn1crypto.__version__,
+
+ description='Fast ASN.1 parser and serializer with definitions for private keys, public keys, certificates, CRL, OCSP, CMS, PKCS#7, PKCS#8, PKCS#12, PKCS#5, X509 and TSA',
+ long_description='Docs for this project are maintained at https://github.com/wbond/asn1crypto#readme.',
+
+ url='https://github.com/wbond/asn1crypto',
+
+ author='wbond',
+ author_email='will@wbond.net',
+
+ license='MIT',
+
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+
+ 'Intended Audience :: Developers',
+
+ 'License :: OSI Approved :: MIT License',
+
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ ],
+
+ keywords='asn1 crypto',
+
+ packages=find_packages(exclude=['tests*'])
+)