aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSergey B Kirpichev <skirpichev@gmail.com>2018-06-12 21:48:44 +0300
committerSergey B Kirpichev <skirpichev@gmail.com>2018-06-12 21:48:44 +0300
commit91ad85bc3074962dcd98c811429cf058eeecdcb1 (patch)
tree5a3d11562fe32afa1c8e327c97ace8e0b77f5617 /setup.py
parent36d864e9584224a6b336654f46b4032994e9b507 (diff)
downloadcachetools-91ad85bc3074962dcd98c811429cf058eeecdcb1.tar.gz
Test on PyPy Python 3 implementation
weakref test was adapted to explicitely call gc.collect(), other tests pass without any modifications. Also add supported Python implementations to classifiers.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 57fa425..3427cb3 100644
--- a/setup.py
+++ b/setup.py
@@ -33,6 +33,8 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries :: Python Modules'
]
)