aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBu Sun Kim <8822365+busunkim96@users.noreply.github.com>2021-05-24 18:16:01 -0600
committerGitHub <noreply@github.com>2021-05-25 00:16:01 +0000
commita9234423cb2b69068fc0d30a5a0ee86a599ab8b7 (patch)
treef2e990dc5db36137534064b62cd55aaaf2bbc816 /setup.py
parent27714c466ad96b6b64c6a0074df1aa6cedf8a9d4 (diff)
downloadgoogle-auth-library-python-a9234423cb2b69068fc0d30a5a0ee86a599ab8b7.tar.gz
fix(dependencies): add urllib3 and requests to aiohttp extra (#755)
Fixes #707.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ef723f8..f2fd4e5 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,11 @@ DEPENDENCIES = (
)
extras = {
- "aiohttp": "aiohttp >= 3.6.2, < 4.0.0dev; python_version>='3.6'",
+ "aiohttp": [
+ "aiohttp >= 3.6.2, < 4.0.0dev; python_version>='3.6'",
+ "requests >= 2.18.0, < 3.0.0dev",
+ "urllib3 >= 1.0.0, <2.0.0dev",
+ ],
"pyopenssl": "pyopenssl>=20.0.0",
"reauth": "pyu2f>=0.1.5",
}