aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2019-02-15 02:30:10 +0800
committerSergey Shepelev <temotor@gmail.com>2019-02-14 23:48:33 +0500
commit724c6d01a4952fee3c77a4aae77108a144524098 (patch)
tree5cdf67630b3a5a061c0d07287614d550d1af2225 /setup.py
parentd26ed028c0eccdfdc94316eaaf07982d8520ee9e (diff)
downloadhttplib2-724c6d01a4952fee3c77a4aae77108a144524098.tar.gz
Fix a warning under Python 3.7
``` `Warning: 'classifiers' should be a list, got type 'tuple'` ``` Related issue: https://bugs.python.org/issue19610
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c3afd0f..d4d2d14 100755
--- a/setup.py
+++ b/setup.py
@@ -87,7 +87,7 @@ A comprehensive HTTP client library, ``httplib2`` supports many features left ou
package_data={"httplib2": ["*.txt"]},
tests_require=read_requirements("requirements-test.txt"),
cmdclass={"test": TestCommand},
- classifiers=(
+ classifiers=[
"Development Status :: 4 - Beta",
"Environment :: Web Environment",
"Intended Audience :: Developers",
@@ -103,5 +103,5 @@ A comprehensive HTTP client library, ``httplib2`` supports many features left ou
"Programming Language :: Python :: 3.7",
"Topic :: Internet :: WWW/HTTP",
"Topic :: Software Development :: Libraries",
- ),
+ ],
)