aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Yu <stinky2nine@users.noreply.github.com>2018-07-26 23:23:35 -0400
committerGitHub <noreply@github.com>2018-07-26 23:23:35 -0400
commitaa1b95b2858ddc7a2f1f1ae07000cfe478f6e340 (patch)
tree6120a184558bb9b220738efd179809506fdbe353 /setup.py
parent89b79a507ae4a00e25bafc1359b9dd5f8559f4f8 (diff)
downloadhttplib2-aa1b95b2858ddc7a2f1f1ae07000cfe478f6e340.tar.gz
Autoformat py files using Black (#105)
* Autoformat all py files using Black * Fix lint errors * Fix indentation errors (https://travis-ci.org/httplib2/httplib2/jobs/408136309) * Refactor three test cases and exclude them on on Travis py27/pypy
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py49
1 files changed, 24 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 0f3a516..c50fe40 100755
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,17 @@
import setuptools
import sys
-pkgdir = {'': 'python%s' % sys.version_info[0]}
-VERSION = '0.11.3'
+pkgdir = {"": "python%s" % sys.version_info[0]}
+VERSION = "0.11.3"
setuptools.setup(
- name='httplib2',
+ name="httplib2",
version=VERSION,
- author='Joe Gregorio',
- author_email='joe@bitworking.org',
- url='https://github.com/httplib2/httplib2',
- description='A comprehensive HTTP client library.',
- license='MIT',
+ author="Joe Gregorio",
+ author_email="joe@bitworking.org",
+ url="https://github.com/httplib2/httplib2",
+ description="A comprehensive HTTP client library.",
+ license="MIT",
long_description="""
A comprehensive HTTP client library, ``httplib2`` supports many features left out of other HTTP libraries.
@@ -57,23 +57,22 @@ A comprehensive HTTP client library, ``httplib2`` supports many features left ou
A large and growing set of unit tests.
""",
package_dir=pkgdir,
- packages=['httplib2'],
- package_data={'httplib2': ['*.txt']},
+ packages=["httplib2"],
+ package_data={"httplib2": ["*.txt"]},
classifiers=(
- 'Development Status :: 4 - Beta',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Software Development :: Libraries',
+ "Development Status :: 4 - Beta",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Software Development :: Libraries",
),
)