aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2020-01-27 13:51:27 -0800
committerDavid Lord <davidism@gmail.com>2020-01-27 13:51:27 -0800
commit4b8d839e1ec7ac4c7e42241e9e4279826bcc3580 (patch)
tree10cb284054e688dc424fa2e3ba118ed68d8d2573 /setup.py
parentbbdafe33ce9f47e3cbfb9415619e354349f11243 (diff)
downloadjinja-4b8d839e1ec7ac4c7e42241e9e4279826bcc3580.tar.gz
start version 3.0.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 3 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 7d94cd3a..050d3e22 100644
--- a/setup.py
+++ b/setup.py
@@ -20,8 +20,6 @@ setup(
"Issue tracker": "https://github.com/pallets/jinja/issues",
},
license="BSD-3-Clause",
- author="Armin Ronacher",
- author_email="armin.ronacher@active-4.com",
maintainer="Pallets",
maintainer_email="contact@palletsprojects.com",
description="A very fast and expressive template engine.",
@@ -33,15 +31,6 @@ setup(
"License :: OSI Approved :: BSD License",
"Operating System :: OS Independent",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Internet :: WWW/HTTP :: Dynamic Content",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Text Processing :: Markup :: HTML",
@@ -49,8 +38,8 @@ setup(
packages=find_packages("src"),
package_dir={"": "src"},
include_package_data=True,
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
- install_requires=["MarkupSafe>=0.23"],
- extras_require={"i18n": ["Babel>=0.8"]},
+ python_requires=">=3.6",
+ install_requires=["MarkupSafe>=1.1"],
+ extras_require={"i18n": ["Babel>=2.1"]},
entry_points={"babel.extractors": ["jinja2 = jinja2.ext:babel_extract[i18n]"]},
)