aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2020-01-09 10:38:52 -0800
committerDavid Lord <davidism@gmail.com>2020-01-09 10:38:52 -0800
commite1e1e7d18b0badcd982b0bbde4ed1ee8d8c19eb3 (patch)
tree7c8812b050ea757947a3c94871895953bde41de0 /setup.py
parent8342180f3913daea28fcd6644a0ba4c69391b189 (diff)
downloadjinja-e1e1e7d18b0badcd982b0bbde4ed1ee8d8c19eb3.tar.gz
move to src directory
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8b1fcc39..70915ff5 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from setuptools import setup
with io.open("README.rst", "rt", encoding="utf8") as f:
readme = f.read()
-with io.open("jinja2/__init__.py", "rt", encoding="utf8") as f:
+with io.open("src/jinja2/__init__.py", "rt", encoding="utf8") as f:
version = re.search(r'__version__ = "(.*?)"', f.read(), re.M).group(1)
setup(
@@ -45,9 +45,10 @@ setup(
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Text Processing :: Markup :: HTML",
],
- packages=find_packages(),
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
+ packages=find_packages("src"),
+ package_dir={"": "src"},
include_package_data=True,
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
install_requires=["MarkupSafe>=0.23"],
extras_require={"i18n": ["Babel>=0.8"]},
entry_points={"babel.extractors": ["jinja2 = jinja2.ext:babel_extract[i18n]"]},