aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIRIS YANG <irisykyang@google.com>2020-08-18 13:17:02 +0000
committerIRIS YANG <irisykyang@google.com>2020-08-18 13:31:16 +0000
commit3121357a0d62a6fe8c9fdcbfe5fd91f12b8f380d (patch)
tree2046b95d53a74b793dd54b7ea6e1b86724b93435 /setup.py
parent81aec74062b5c629b3408f7f3d18343ec0bbcab8 (diff)
downloadjinja-3121357a0d62a6fe8c9fdcbfe5fd91f12b8f380d.tar.gz
Revert "Revert "Import external/python/jinja into master""
This reverts commit 81aec74062b5c629b3408f7f3d18343ec0bbcab8. Reason for revert: It seems Jinja folder is empty. Revert the revert to add files back. Third-party review: ag/11821018 Change-Id: I4429a3b3448cdf2eb62ec388392a2a29fa3dbc21
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..f5ad968e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,40 @@
+import re
+
+from setuptools import find_packages
+from setuptools import setup
+
+with open("src/jinja2/__init__.py", "rt", encoding="utf8") as f:
+ version = re.search(r'__version__ = "(.*?)"', f.read(), re.M).group(1)
+
+setup(
+ name="Jinja2",
+ version=version,
+ url="https://palletsprojects.com/p/jinja/",
+ project_urls={
+ "Documentation": "https://jinja.palletsprojects.com/",
+ "Code": "https://github.com/pallets/jinja",
+ "Issue tracker": "https://github.com/pallets/jinja/issues",
+ },
+ license="BSD-3-Clause",
+ maintainer="Pallets",
+ maintainer_email="contact@palletsprojects.com",
+ description="A very fast and expressive template engine.",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Topic :: Internet :: WWW/HTTP :: Dynamic Content",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: Markup :: HTML",
+ ],
+ packages=find_packages("src"),
+ package_dir={"": "src"},
+ include_package_data=True,
+ python_requires=">=3.6",
+ install_requires=["MarkupSafe>=1.1"],
+ extras_require={"i18n": ["Babel>=2.1"]},
+ entry_points={"babel.extractors": ["jinja2 = jinja2.ext:babel_extract[i18n]"]},
+)