summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Withers <chris@withers.org>2020-01-13 08:02:15 +0000
committerChris Withers <chris@withers.org>2020-01-13 08:05:25 +0000
commit4680a9654e8485dd5b8ed809af4ff0c62df3b493 (patch)
tree921905a49f9dade0fada30d0f67ae986eb964221 /setup.py
parentd1118fbc2a6044121625a9bc4a9a46a308b08f01 (diff)
downloadmock-4680a9654e8485dd5b8ed809af4ff0c62df3b493.tar.gz
move __version__ to __init__.py so we don't have to modify the mock.py from cpython.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d47345f..6f5ff41 100755
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,6 @@ import setuptools
setuptools.setup(
version=re.search("__version__ = '([^']+)'",
- open(join('mock', 'mock.py')).read()).group(1),
+ open(join('mock', '__init__.py')).read()).group(1),
long_description=open('README.rst').read(),
)