summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <rbtcollins@hp.com>2015-07-10 10:50:14 +1200
committerRobert Collins <rbtcollins@hp.com>2015-07-10 10:51:04 +1200
commit51346f488cd28e6a9a6727901922a4cff2df3714 (patch)
tree447a63cde876788a552033b1c11415c535f84c04 /setup.py
parente7c30fb1e98a8751cbe7ba3aa116b131b07364f3 (diff)
downloadmock-51346f488cd28e6a9a6727901922a4cff2df3714.tar.gz
Convert to a package, use pbr, update metadata.
In particular this changes the author from Michael to the testing-cabal group.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py75
1 files changed, 5 insertions, 70 deletions
diff --git a/setup.py b/setup.py
index 3083f81..c72c231 100755
--- a/setup.py
+++ b/setup.py
@@ -1,72 +1,7 @@
-#! /usr/bin/env python
+#!/usr/bin/env python
+import setuptools
-# Copyright (C) 2007-2012 Michael Foord & the mock team
-# E-mail: fuzzyman AT voidspace DOT org DOT uk
-# http://www.voidspace.org.uk/python/mock/
-from __version__ import __version__
-
-import os
-
-from setuptools import setup
-
-NAME = 'mock'
-MODULES = ['mock']
-DESCRIPTION = 'A Python Mocking and Patching Library for Testing'
-
-URL = "http://www.voidspace.org.uk/python/mock/"
-
-readme = os.path.join(os.path.dirname(__file__), 'README.txt')
-LONG_DESCRIPTION = open(readme).read()
-
-CLASSIFIERS = [
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Programming Language :: Python :: Implementation :: Jython',
- 'Operating System :: OS Independent',
- 'Topic :: Software Development :: Libraries',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: Software Development :: Testing',
-]
-
-AUTHOR = 'Michael Foord'
-AUTHOR_EMAIL = 'michael@voidspace.org.uk'
-KEYWORDS = ("testing test mock mocking unittest patching "
- "stubs fakes doubles").split(' ')
-
-params = dict(
- name=NAME,
- version=__version__,
- py_modules=MODULES,
-
- # metadata for upload to PyPI
- author=AUTHOR,
- author_email=AUTHOR_EMAIL,
- description=DESCRIPTION,
- long_description=LONG_DESCRIPTION,
- keywords=KEYWORDS,
- url=URL,
- classifiers=CLASSIFIERS,
- extras_require={
- ':python_version<"3.3"': ['funcsigs'],
- 'test': ['unittest2'],
- },
- install_requires=['six'],
- tests_require=['unittest2'],
- test_suite='unittest2.collector',
-)
-
-
-setup(**params)
+setuptools.setup(
+ setup_requires=['pbr'],
+ pbr=True)