summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <rbtcollins@hp.com>2015-07-15 12:06:50 +1200
committerRobert Collins <rbtcollins@hp.com>2015-07-15 12:06:50 +1200
commite3d6580202eb34a1db134b0d66e46c831fb454f3 (patch)
tree7792c72baf34bb503e5c139db815c197c037cd3c /setup.py
parent0cba1baa0ffba36787d5e6871efa45f3dd4cc1e1 (diff)
downloadmock-e3d6580202eb34a1db134b0d66e46c831fb454f3.tar.gz
Closes #279: setuptools.version is too new.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 52921a2..161016b 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ import sys
# Setuptools 17.1 is required, and setup_requires cannot upgrade setuptools
# in-place, nor trigger the use of a newer version. Abort cleanly up-front.
setuptools_required = StrictVersion("17.1")
-setuptools_installed = StrictVersion(setuptools.version.__version__)
+setuptools_installed = StrictVersion(setuptools.__version__)
if setuptools_installed < setuptools_required:
sys.stderr.write(
"mock requires setuptools>=17.1. Aborting installation\n")