summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Withers <chris@withers.org>2019-04-30 16:15:33 +0100
committerChris Withers <chris@withers.org>2019-04-30 16:15:44 +0100
commit4dcbc56664babb11d4a3583d8372f81d545149d2 (patch)
tree2b51c68ec8300cb8ac6b33b05c83426858de5322 /setup.py
parent8b83f7c6151e9bf699a3ffe667a86bf462256d1c (diff)
downloadmock-4dcbc56664babb11d4a3583d8372f81d545149d2.tar.gz
remove pbr and replace with simpler to understand and discover code.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 7 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 6154ba7..d47345f 100755
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,10 @@
-#!/usr/bin/env python
+import re
+from os.path import join
+
import setuptools
setuptools.setup(
- setup_requires=['pbr>=1.3', 'setuptools>=17.1'],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
- pbr=True)
+ version=re.search("__version__ = '([^']+)'",
+ open(join('mock', 'mock.py')).read()).group(1),
+ long_description=open('README.rst').read(),
+)