aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py37
1 files changed, 15 insertions, 22 deletions
diff --git a/setup.py b/setup.py
index 47d86b7..686d1db 100644
--- a/setup.py
+++ b/setup.py
@@ -26,11 +26,11 @@ from setuptools import setup
import oauth2client
-if sys.version_info < (2, 7):
- print('oauth2client requires python2 version >= 2.7.', file=sys.stderr)
+if sys.version_info < (2, 6):
+ print('oauth2client requires python2 version >= 2.6.', file=sys.stderr)
sys.exit(1)
-if (3, 1) <= sys.version_info < (3, 4):
- print('oauth2client requires python3 version >= 3.4.', file=sys.stderr)
+if (3, 1) <= sys.version_info < (3, 3):
+ print('oauth2client requires python3 version >= 3.3.', file=sys.stderr)
sys.exit(1)
install_requires = [
@@ -41,36 +41,29 @@ install_requires = [
'six>=1.6.1',
]
-long_desc = """
-oauth2client is a client library for OAuth 2.0.
-
-Note: oauth2client is now deprecated. No more features will be added to the
- libraries and the core team is turning down support. We recommend you use
- `google-auth <https://google-auth.readthedocs.io>`__ and
- `oauthlib <http://oauthlib.readthedocs.io/>`__.
-"""
+long_desc = """The oauth2client is a client library for OAuth 2.0."""
version = oauth2client.__version__
setup(
- name='oauth2client',
+ name="oauth2client",
version=version,
- description='OAuth 2.0 client library',
+ description="OAuth 2.0 client library",
long_description=long_desc,
- author='Google Inc.',
- author_email='jonwayne+oauth2client@google.com',
- url='http://github.com/google/oauth2client/',
+ author="Google Inc.",
+ url="http://github.com/google/oauth2client/",
install_requires=install_requires,
- packages=find_packages(exclude=('tests*',)),
- license='Apache 2.0',
- keywords='google oauth 2.0 http client',
+ packages=find_packages(),
+ license="Apache 2.0",
+ keywords="google oauth 2.0 http client",
classifiers=[
'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Development Status :: 7 - Inactive',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'License :: OSI Approved :: Apache Software License',
'Operating System :: POSIX',