aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2011-02-17 18:35:16 +0000
committerelie <elie>2011-02-17 18:35:16 +0000
commit8b513895caeda00b34f662bec79238a5bf636383 (patch)
treec0d45c812a29111261b57d33e0a0c05bccfb9636 /setup.py
downloadpyasn1-modules-8b513895caeda00b34f662bec79238a5bf636383.tar.gz
Initial revision
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..3fd40dd
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,43 @@
+#!/usr/bin/env python
+import sys
+import string
+
+def howto_install_setuptools():
+ print """Error: You need setuptools Python package!
+
+It's very easy to install it, just type (as root on Linux):
+ wget http://peak.telecommunity.com/dist/ez_setup.py
+ python ez_setup.py
+"""
+
+try:
+ from setuptools import setup
+ params = {
+ 'install_requires': [ 'pyasn1' ],
+ 'zip_safe': True
+ }
+except ImportError:
+ for arg in sys.argv:
+ if string.find(arg, 'egg') != -1:
+ howto_install_setuptools()
+ sys.exit(1)
+ from distutils.core import setup
+ if sys.version_info > (2, 2):
+ params = {
+ 'requires': [ 'pyasn1' ]
+ }
+ else:
+ params = {}
+
+params.update( {
+ 'name': 'pyasn1-modules',
+ 'version': '0.0.1a',
+ 'description': 'ASN.1 modules',
+ 'author': 'Ilya Etingof',
+ 'author_email': 'ilya@glas.net',
+ 'url': 'http://sourceforge.net/projects/pyasn1/',
+ 'license': 'BSD',
+ 'packages': [ 'pyasn1_modules' ]
+ } )
+
+apply(setup, (), params)