aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2012-07-23 16:35:59 +0000
committerelie <elie>2012-07-23 16:35:59 +0000
commit1536a5e9d31ebee76dfbd77def16be1a5c09495e (patch)
tree6ef37d9500cc52095669fdd4f2b2079825bdaf43 /setup.py
parent0d540ea1dcb373258e1b9969d534520d88e8da10 (diff)
downloadpyasn1-modules-1536a5e9d31ebee76dfbd77def16be1a5c09495e.tar.gz
the distribute package mentioned
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 19 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 42b170a..41b9941 100644
--- a/setup.py
+++ b/setup.py
@@ -25,13 +25,28 @@ Topic :: Security :: Cryptography
Topic :: Software Development :: Libraries :: Python Modules
"""
+def howto_install_distribute():
+ print("""
+ Error: You need the distribute Python package!
+
+ It's very easy to install it, just type (as root on Linux):
+
+ wget http://python-distribute.org/distribute_setup.py
+ python distribute_setup.py
+
+ Then you could make eggs from this package.
+""")
+
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
+
wget http://peak.telecommunity.com/dist/ez_setup.py
python ez_setup.py
+
+ Then you could make eggs from this package.
""")
try:
@@ -44,7 +59,10 @@ except ImportError:
import sys
for arg in sys.argv:
if arg.find('egg') != -1:
- howto_install_setuptools()
+ if sys.version_info[0] > 2:
+ howto_install_distribute()
+ else:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
params = {}