aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIlya Etingof <ietingof@redhat.com>2017-06-01 22:36:02 +0200
committerIlya Etingof <ietingof@redhat.com>2017-06-01 22:36:02 +0200
commitcd2de07de7cbc4c0df7958ff26c3e109ad54b11e (patch)
tree78918d409c8298dd2866442f8c62f2527a5361ee /setup.py
parent5f919aa833afe37c393457713b247ff3f430bcf0 (diff)
downloadpyasn1-modules-cd2de07de7cbc4c0df7958ff26c3e109ad54b11e.tar.gz
drop "distribute" support, update setuptools URL
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py43
1 files changed, 17 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index e9ea4a5..8b754c6 100644
--- a/setup.py
+++ b/setup.py
@@ -5,13 +5,18 @@
# Copyright (c) 2005-2017, Ilya Etingof <etingof@gmail.com>
# License: http://pyasn1.sf.net/license.html
#
-"""A collection of ASN.1-based protocols modules.
+import sys
+
+doclines = """A collection of ASN.1-based protocols modules.
A collection of ASN.1 modules expressed in form of pyasn1 classes.
Includes protocols PDUs definition (SNMP, LDAP etc.) and various
data structures (X.509, PKCS etc.).
"""
+doclines = [x.strip() for x in doclines.split('\n') if x]
+
+
classifiers = """\
Development Status :: 5 - Production/Stable
Environment :: Console
@@ -41,57 +46,43 @@ Topic :: Software Development :: Libraries :: Python Modules
"""
-def howto_install_distribute():
- print("""
- Error: You need the distribute Python package!
-
- It's very easy to install it, just type (as root on Linux):
-
- wget http://python-distribute.org/distribute_setup.py
- python distribute_setup.py
-
- Then you could make eggs from this package.
-""")
-
-
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
- wget http://peak.telecommunity.com/dist/ez_setup.py
+ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py
Then you could make eggs from this package.
""")
+if sys.version_info[:2] < (2, 4):
+ print("ERROR: this package requires Python 2.4 or later!")
+ sys.exit(1)
+
try:
- from setuptools import setup
+ from setuptools import setup, Command
params = {
'install_requires': ['pyasn1>=0.1.8'],
'zip_safe': True
}
-except ImportError:
- import sys
+except ImportError:
for arg in sys.argv:
- if arg.find('egg') != -1:
- if sys.version_info[0] > 2:
- howto_install_distribute()
- else:
- howto_install_setuptools()
+ if 'egg' in arg:
+ howto_install_setuptools()
sys.exit(1)
- from distutils.core import setup
+ from distutils.core import setup, Command
params = {}
+
if sys.version_info[:2] > (2, 4):
params['requires'] = ['pyasn1(>=0.1.8)']
-doclines = [x.strip() for x in (__doc__ or '').split('\n') if x]
-
params.update(
{'name': 'pyasn1-modules',
'version': open('pyasn1_modules/__init__.py').read().split('\'')[1],