summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCeridwen <ceridwen@users.noreply.github.com>2017-10-19 16:01:26 -0700
committerCeridwen <ceridwen@users.noreply.github.com>2017-10-19 16:01:26 -0700
commit3da28067f306582a10b798ba527356d62c1f4f86 (patch)
tree00e46f5ed7640cbd9e67b4a8d3db64dda6004581 /setup.py
parentc750a5beec815ff2caccdd9bb76f54e11901e1a8 (diff)
downloadpytest-3da28067f306582a10b798ba527356d62c1f4f86.tar.gz
Replace introspection in compat.getfuncargnames() with inspect/funcsigs.signature
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 68b8ec065..61ae1587f 100644
--- a/setup.py
+++ b/setup.py
@@ -44,16 +44,19 @@ def has_environment_marker_support():
def main():
install_requires = ['py>=1.4.34', 'six>=1.10.0', 'setuptools']
+ extras_require = {}
# if _PYTEST_SETUP_SKIP_PLUGGY_DEP is set, skip installing pluggy;
# used by tox.ini to test with pluggy master
if '_PYTEST_SETUP_SKIP_PLUGGY_DEP' not in os.environ:
install_requires.append('pluggy>=0.4.0,<0.5')
- extras_require = {}
if has_environment_marker_support():
+ extras_require[':python_version<"3.0"'] = ['funcsigs']
extras_require[':sys_platform=="win32"'] = ['colorama']
else:
if sys.platform == 'win32':
install_requires.append('colorama')
+ if sys.version_info < (3, 0):
+ install_requires.append('funcsigs')
setup(
name='pytest',