summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthony Sottile <asottile@umich.edu>2018-06-07 21:55:50 -0700
committerAnthony Sottile <asottile@umich.edu>2018-06-07 22:01:14 -0700
commitc1d9ca81df5364417317fd779e73d9ff85fe5d35 (patch)
treeaccde6a640fde794cd4203a7bceac04f7a95d977 /setup.py
parentf389a4e91f9c9b3ff4f4bb29ee0eb208b5a9adb6 (diff)
downloadpytest-c1d9ca81df5364417317fd779e73d9ff85fe5d35.tar.gz
Remove setup.py test now that it's broken
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 1 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 3f5ed39be..e799d53bf 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@ import os
import sys
import setuptools
import pkg_resources
-from setuptools import setup, Command
+from setuptools import setup
classifiers = [
"Development Status :: 6 - Mature",
@@ -102,7 +102,6 @@ def main():
entry_points={"console_scripts": ["pytest=pytest:main", "py.test=pytest:main"]},
classifiers=classifiers,
keywords="test unittest",
- cmdclass={"test": PyTest},
# the following should be enabled for release
setup_requires=["setuptools-scm"],
package_dir={"": "src"},
@@ -115,24 +114,5 @@ def main():
)
-class PyTest(Command):
- user_options = []
-
- def initialize_options(self):
- pass
-
- def finalize_options(self):
- pass
-
- def run(self):
- import subprocess
-
- python_path = [x for x in os.environ.get("PYTHONPATH", "").split(":") if x]
- python_path.insert(0, os.getcwd())
- os.environ["PYTHONPATH"] = ":".join(python_path)
- errno = subprocess.call([sys.executable, "pytest.py", "--ignore=doc"])
- raise SystemExit(errno)
-
-
if __name__ == "__main__":
main()