summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLawrence Mitchell <lawrence.mitchell@imperial.ac.uk>2017-07-26 10:58:38 +0100
committerLawrence Mitchell <lawrence.mitchell@imperial.ac.uk>2017-07-26 14:41:10 +0100
commitf8bd693f8348dbf5b0536b5529cc5a4884bf06b7 (patch)
treee7dbfb42d18a4736ae7c24089c5fc9b7dcf62e34 /setup.py
parenta546a612bde02292488b6f9b3185a950d61fbe94 (diff)
downloadpytest-f8bd693f8348dbf5b0536b5529cc5a4884bf06b7.tar.gz
Add ordereddict to install_requires for py26
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 751868c04..55607912b 100644
--- a/setup.py
+++ b/setup.py
@@ -46,11 +46,12 @@ def main():
install_requires = ['py>=1.4.33', 'setuptools'] # pluggy is vendored in _pytest.vendored_packages
extras_require = {}
if has_environment_marker_support():
- extras_require[':python_version=="2.6"'] = ['argparse']
+ extras_require[':python_version=="2.6"'] = ['argparse', 'ordereddict']
extras_require[':sys_platform=="win32"'] = ['colorama']
else:
if sys.version_info < (2, 7):
install_requires.append('argparse')
+ install_requires.append('ordereddict')
if sys.platform == 'win32':
install_requires.append('colorama')