aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAza Tulepbergenov <aza.tulepber@gmail.com>2021-10-19 11:17:49 -0700
committerGitHub <noreply@github.com>2021-10-19 14:17:49 -0400
commitef6f0fcfdfe771172056e35e3c990998b3b00416 (patch)
treeffe756fb2b0ccf5e3658be59265b8656c17e9061 /setup.py
parent09cf285536fee519106db335670e1560b0846bcf (diff)
downloadpython-api-core-ef6f0fcfdfe771172056e35e3c990998b3b00416.tar.gz
feat: add 'GoogleAPICallError.error_details' property (#286)
Based on 'google.rpc.status.details'.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d150bc0..ddc5600 100644
--- a/setup.py
+++ b/setup.py
@@ -29,14 +29,14 @@ description = "Google API client core library"
# 'Development Status :: 5 - Production/Stable'
release_status = "Development Status :: 5 - Production/Stable"
dependencies = [
- "googleapis-common-protos >= 1.6.0, < 2.0dev",
+ "googleapis-common-protos >= 1.52.0, < 2.0dev",
"protobuf >= 3.12.0",
"google-auth >= 1.25.0, < 3.0dev",
"requests >= 2.18.0, < 3.0.0dev",
"setuptools >= 40.3.0",
]
extras = {
- "grpc": "grpcio >= 1.33.2, < 2.0dev",
+ "grpc": ["grpcio >= 1.33.2, < 2.0dev", "grpcio-status >= 1.33.2, < 2.0dev"],
"grpcgcp": "grpcio-gcp >= 0.2.2",
"grpcio-gcp": "grpcio-gcp >= 0.2.2",
}