aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2020-12-10 15:19:02 -0500
committerGitHub <noreply@github.com>2020-12-10 15:19:02 -0500
commitfdbed0f0cbae8de21c73338a6817f8aa79cef4c9 (patch)
tree275f901acf4102b2510182e9550fdc74605e605b /setup.py
parentcbf14b314bee8652c6523845116125db232bd0e5 (diff)
downloadpython-api-core-fdbed0f0cbae8de21c73338a6817f8aa79cef4c9.tar.gz
feat: add support for Python 3.9 (#111)
Also, add missing declaration of support for Python 3.8. Closes #110.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c8fd257..baea1c0 100644
--- a/setup.py
+++ b/setup.py
@@ -53,7 +53,7 @@ package_root = os.path.abspath(os.path.dirname(__file__))
version = {}
with open(os.path.join(package_root, "google/api_core/version.py")) as fp:
exec(fp.read(), version)
-version = version['__version__']
+version = version["__version__"]
readme_filename = os.path.join(package_root, "README.rst")
with io.open(readme_filename, encoding="utf-8") as readme_file:
@@ -91,6 +91,8 @@ setuptools.setup(
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
"Operating System :: OS Independent",
"Topic :: Internet",
],