aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 14:05:42 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 14:15:39 +0200
commit1e22d2eb03c7a29a0befe1febf951af9e46ce470 (patch)
treebb930d3711b877a6ce84670287358bcae8ac0d48 /setup.py
parent7424c69bde598a145b7d3807e6c367ac4b922bff (diff)
downloadrsa-1e22d2eb03c7a29a0befe1febf951af9e46ce470.tar.gz
Drop support for Python 2 and 3.4
Some of our development dependencies, like Sphinx, have already dropped support for Python 2. This makes it harder for this project to update its dependencies. Since Python 2 only has a few more months to live, I think it's fine to drop support now. Python 3.4 has already reached its end-of-life date. Python-RSA now only supports Python 3.5 and newer. Python 3.5 support is intended to last until its end-of-life date of 2019-09-13: https://devguide.python.org/#status-of-python-branches
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 0 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ad2603e..2fc08ef 100755
--- a/setup.py
+++ b/setup.py
@@ -44,10 +44,7 @@ if __name__ == '__main__':
'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',