aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 21 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index dbc7ebc..f5d59ad 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
-# -*- coding: utf-8 -*-
-import sys
+"""Setuptools entry point."""
+import codecs
+import os
try:
from setuptools import setup
@@ -7,7 +8,7 @@ except ImportError:
from distutils.core import setup
-CLASSIFIERS=[
+CLASSIFIERS = [
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
@@ -15,18 +16,23 @@ CLASSIFIERS=[
'Operating System :: OS Independent',
'Programming Language :: Python',
'Topic :: Software Development :: Libraries :: Python Modules'
- ]
+]
-setup(
- name='timeout-decorator',
- version='0.2.1',
- description='Timeout decorator',
- long_description = open('README.md').read(),
- author='PN',
- author_email='pn.appdev@gmail.com',
- url='https://github.com/pnpnpn/timeout-decorator',
- packages=['timeout_decorator'],
- install_requires=[],
- classifiers=CLASSIFIERS)
+dirname = os.path.dirname(__file__)
+long_description = (
+ codecs.open(os.path.join(dirname, 'README.rst'), encoding='utf-8').read() + '\n' +
+ codecs.open(os.path.join(dirname, 'CHANGES.rst'), encoding='utf-8').read()
+)
+setup(
+ name='timeout-decorator',
+ version='0.3.0',
+ description='Timeout decorator',
+ long_description=long_description,
+ author='Patrick Ng',
+ author_email='pn.appdev@gmail.com',
+ url='https://github.com/pnpnpn/timeout-decorator',
+ packages=['timeout_decorator'],
+ install_requires=[],
+ classifiers=CLASSIFIERS)