aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIan Cordasco <graffatcolmingov@gmail.com>2015-10-04 13:47:55 -0500
committerIan Cordasco <graffatcolmingov@gmail.com>2015-10-04 13:48:41 -0500
commit2ecd303d0a52895f263cd775a3113b4467062b10 (patch)
tree3a5ce01beeb3338893ef1b7e7972dd9bbbfd9d47 /setup.py
parent224c5f7db47ab55b30632d60ea84e7a69b8a95bd (diff)
downloaduritemplates-2ecd303d0a52895f263cd775a3113b4467062b10.tar.gz
Clean up and actually run tests from fixtures
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index d260c40..27b1f5d 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,3 @@
-#!/usr/bin/env python
-
import sys
import os
@@ -7,7 +5,7 @@ packages = [
'uritemplate'
]
-from distutils.core import setup
+from setuptools import setup
if sys.argv[-1] in ("submit", "publish"):
os.system("python setup.py sdist upload")
@@ -39,6 +37,8 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
],
)