aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..59f03ba
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,39 @@
+from setuptools import setup
+
+from uritemplate import __version__
+
+packages = [
+ 'uritemplate'
+]
+
+setup(
+ name="uritemplate",
+ version=__version__,
+ description='URI templates',
+ long_description="\n\n".join([open("README.rst").read(),
+ open("HISTORY.rst").read()]),
+ license="BSD 3-Clause License or Apache License, Version 2.0",
+ author="Ian Cordasco",
+ author_email="graffatcolmingov@gmail.com",
+ url="https://uritemplate.readthedocs.org",
+ packages=packages,
+ package_data={'': ['LICENSE', 'AUTHORS.rst']},
+ include_package_data=True,
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved',
+ 'License :: OSI Approved :: BSD License',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ ],
+)