aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 9 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index cae605c..170e003 100644
--- a/setup.py
+++ b/setup.py
@@ -6,12 +6,17 @@ packages = [
'uritemplate'
]
+with open("README.rst") as file:
+ readme = file.read()
+
+with open("HISTORY.rst") as file:
+ history = file.read()
+
setup(
name="uritemplate",
version=__version__,
description='URI templates',
- long_description="\n\n".join([open("README.rst").read(),
- open("HISTORY.rst").read()]),
+ long_description="\n\n".join([readme, history]),
license="BSD 3-Clause License or Apache License, Version 2.0",
author="Ian Stapleton Cordasco",
author_email="graffatcolmingov@gmail.com",
@@ -34,6 +39,8 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
],
)