aboutsummaryrefslogtreecommitdiff
path: root/nearby/crypto/crypto_provider_openssl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nearby/crypto/crypto_provider_openssl/Cargo.toml')
-rw-r--r--nearby/crypto/crypto_provider_openssl/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/nearby/crypto/crypto_provider_openssl/Cargo.toml b/nearby/crypto/crypto_provider_openssl/Cargo.toml
index 8fa6faa..84d4380 100644
--- a/nearby/crypto/crypto_provider_openssl/Cargo.toml
+++ b/nearby/crypto/crypto_provider_openssl/Cargo.toml
@@ -5,15 +5,16 @@ edition.workspace = true
publish.workspace = true
[dependencies]
-crypto_provider = { path = "../crypto_provider", default-features = false, features = ["alloc", "std"] }
+crypto_provider = { workspace = true, features = ["alloc", "std"] }
+crypto_provider_stubs.workspace = true
openssl.workspace = true
cfg-if.workspace = true
-ouroboros = "0.15.5"
+ouroboros = "0.17.0"
[features]
default = []
-boringssl = ["openssl/unstable_boringssl", "crypto_provider/gcm_siv"]
+boringssl = ["openssl/unstable_boringssl"]
[dev-dependencies]
crypto_provider_test.workspace = true