aboutsummaryrefslogtreecommitdiff
path: root/nearby/presence/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'nearby/presence/CMakeLists.txt')
-rw-r--r--nearby/presence/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/nearby/presence/CMakeLists.txt b/nearby/presence/CMakeLists.txt
new file mode 100644
index 0000000..e9363b8
--- /dev/null
+++ b/nearby/presence/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Copyright 2022 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.0)
+
+project(ldt)
+
+set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -DDEBUG")
+
+add_compile_options(-Wall -g -O1 -Wno-deprecated -Wno-deprecated-declarations)
+
+# we need at least version 3.0.6 for the core.h header used in the fuzzers
+find_package(OpenSSL 3.0.5 REQUIRED)
+if ( OPENSSL_FOUND )
+ message(STATUS "OpenSSL Found: ${OPENSSL_VERSION}")
+ message(STATUS "OpenSSL Include: ${OPENSSL_INCLUDE_DIR}")
+ message(STATUS "OpenSSL Libraries: ${OPENSSL_LIBRARIES}")
+endif()
+
+add_subdirectory(ldt_np_c_sample)
+add_subdirectory(ldt_np_adv_ffi_fuzz)
+