aboutsummaryrefslogtreecommitdiff
path: root/nearby/presence/np_cpp_ffi/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'nearby/presence/np_cpp_ffi/tests/CMakeLists.txt')
-rw-r--r--nearby/presence/np_cpp_ffi/tests/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/nearby/presence/np_cpp_ffi/tests/CMakeLists.txt b/nearby/presence/np_cpp_ffi/tests/CMakeLists.txt
new file mode 100644
index 0000000..bddda64
--- /dev/null
+++ b/nearby/presence/np_cpp_ffi/tests/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Copyright 2023 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_executable(
+ np_ffi_tests
+ deserialize_result_tests.cc
+ deserialize_v0_tests.cc
+ deserialize_v1_tests.cc
+ global_config_tests.cc
+ credential_book_tests.cc
+ byte_buffer_tests.cc
+)
+
+target_link_libraries(
+ np_ffi_tests
+ nearby_protocol
+ shared_test_util
+ GTest::gtest_main
+)
+
+if (UNIX)
+ target_link_libraries(
+ np_ffi_tests
+ dl -fsanitize=address
+ )
+elseif (MSVC)
+ target_link_libraries(
+ np_ffi_tests
+ bcrypt ntdll userenv ws2_32
+ )
+endif ()
+
+gtest_discover_tests(np_ffi_tests)