aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 16 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 62b5f7e..ee8e94e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,27 +3,33 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "aho-corasick"
-version = "0.7.18"
+version = "0.7.20"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/aho-corasick-debug", "/ci/*", "/.travis.yml", "/appveyor.yml"]
+exclude = ["/aho-corasick-debug"]
autotests = false
description = "Fast multiple substring searching."
homepage = "https://github.com/BurntSushi/aho-corasick"
readme = "README.md"
-keywords = ["string", "search", "text", "aho", "multi"]
+keywords = [
+ "string",
+ "search",
+ "text",
+ "aho",
+ "multi",
+]
categories = ["text-processing"]
-license = "Unlicense/MIT"
+license = "Unlicense OR MIT"
repository = "https://github.com/BurntSushi/aho-corasick"
+
[profile.bench]
debug = true
@@ -32,6 +38,7 @@ debug = true
[lib]
name = "aho_corasick"
+
[dependencies.memchr]
version = "2.4.0"
default-features = false