summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Walbran <qwandor@google.com>2023-11-21 14:06:43 +0000
committerAndrew Walbran <qwandor@google.com>2023-12-05 22:17:30 +0000
commit085777ee9c739895b15b8db17a629826c469facd (patch)
treecaceb3d988b3cd1bab30d1e0d2fbe5e0ff398dd6 /Cargo.toml
parent57bad3f55182c6dbf120f615cdeb0289469256c4 (diff)
downloadasn1-rs-impl-085777ee9c739895b15b8db17a629826c469facd.tar.gz
Import asn1-rs-impl crate.upstream
Request Document: go/android-rust-importing-crates For CL Reviewers: go/android3p#cl-review For Build Team: go/ab-third-party-imports Bug: 312436741 Test: Treehugger Change-Id: Ie6e96450b8bd28dfaec21f2a9af7d3827af8c2ca
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..261b72f
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,31 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "asn1-rs-impl"
+version = "0.1.0"
+authors = ["Pierre Chifflier <chifflier@wzdftpd.net>"]
+description = "Implementation details for the `asn1-rs` crate"
+homepage = "https://github.com/rusticata/asn1-rs"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rusticata/asn1-rs.git"
+
+[lib]
+proc-macro = true
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1"