aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 11 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0e91d4a..b8058ec 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
rust-version = "1.56"
name = "async-trait"
-version = "0.1.67"
+version = "0.1.73"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Type erasure for async trait methods"
documentation = "https://docs.rs/async-trait"
@@ -27,36 +27,37 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/async-trait"
[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
targets = ["x86_64-unknown-linux-gnu"]
[lib]
proc-macro = true
[dependencies.proc-macro2]
-version = "1.0"
+version = "1.0.63"
[dependencies.quote]
-version = "1.0"
+version = "1.0.29"
[dependencies.syn]
-version = "2.0"
+version = "2.0.23"
features = [
"full",
"visit-mut",
]
[dev-dependencies.futures]
-version = "0.3"
+version = "0.3.28"
[dev-dependencies.rustversion]
-version = "1.0"
+version = "1.0.13"
[dev-dependencies.tracing]
-version = "0.1.14"
+version = "0.1.37"
[dev-dependencies.tracing-attributes]
-version = "0.1.14"
+version = "0.1.26"
[dev-dependencies.trybuild]
-version = "1.0.49"
+version = "1.0.81"
features = ["diff"]